Limited PAYMILL office availability
Incident Report for Paymill GmbH
Resolved
This incident has been resolved.
Posted 9 months ago. Dec 18, 2018 - 17:28 CET
Update
The services are working again.

Thank you very much for your understanding,

The PAYMILL Team
Posted 9 months ago. Dec 18, 2018 - 14:17 CET
Investigating
We are currently investing a degraded performance within our office network. Phone and email availability might be limited.
The transaction processing (API and Tokenization) and Merchant Centre are not affected and do work properly.
Posted 9 months ago. Dec 18, 2018 - 09:24 CET
This incident affected: PAYMILL Phone Lines.