Transaction processing interruption
Incident Report for Paymill GmbH
Resolved
The interruption in transaction processing is solved since 11:35 am (CET). Systems are running as expected again.

Thank you very much for your patience and we're sorry if this caused any inconvenience.

If you have any further questions please contact our support team via support@paymill.com.
Posted May 18, 2016 - 11:51 CEST
Investigating
One of our acquirers is currently experiencing an issue in transaction processing. The interruption started at 11:00 am (CEST), when the issue was also identified.

We’ve got all teams working hard on a solution and we’ll keep you posted on our progress.

If you have any further questions please contact our support team at: support@paymill.com for concrete details which acquirer it is.
Posted May 18, 2016 - 11:18 CEST