Transaction processing interruption
Incident Report for Paymill GmbH
Resolved
The interruption in transaction processing is solved since 09:44 am (CET). Systems are running as expected again.

Thank you very much for your patience and we're sorry if this caused any inconvenience.

If you have any further questions please contact our support team via support@paymill.com.
Posted Mar 23, 2016 - 09:58 CET
Investigating
Since 07:50 am (CET) one of our backend systems has problems in transaction processing. Their teams are working hard to resolve the issue.

Thank you very much for your patience and we're sorry if this caused any inconvenience.

If you have any further questions please contact our support team at: support@paymill.com
Posted Mar 23, 2016 - 08:42 CET