Transaction processing interruption of one acquirer
Incident Report for Paymill GmbH
Resolved
This incident has been resolved. Please accept our apologies for any inconvenience created.
Posted almost 3 years ago. Nov 10, 2016 - 16:40 CET
Investigating
One of our acquirers is currently experiencing an issue in transaction processing.
We’ve got all teams working hard on a solution and we’ll keep you posted on our progress.
Posted almost 3 years ago. Nov 10, 2016 - 14:32 CET