Partial Network Irregularity
Incident Report for Paymill GmbH
Resolved
This incident has been resolved. Please accept our apologies for any inconvenience created.
Posted almost 3 years ago. Oct 13, 2016 - 16:35 CEST
Monitoring
The incident has been reported as resolved and will be monitored during the next hours.
All systems are working properly again.
Posted almost 3 years ago. Oct 13, 2016 - 11:15 CEST
Investigating
An irregularity in parts of the network has been reported by some merchants.
This is currently being investigated.
Posted almost 3 years ago. Oct 13, 2016 - 11:02 CEST