Login to Merchant Centre is not possible for some merchants
Incident Report for Paymill GmbH
Resolved
This incident has been resolved. Please accept our apologies for any inconvenience created.
Posted almost 3 years ago. Sep 29, 2016 - 14:33 CEST
Investigating
A few merchants reported to us that they are not able to log into to the PAYMILL Merchant Centre.
We are currently investigating this.
The majority of our merchants is not affected and also all other services do work properly.
Posted almost 3 years ago. Sep 29, 2016 - 11:24 CEST