Partial Network Irregularity
Incident Report for Paymill GmbH
Resolved
This incident has been resolved.

Please accept our apologies for any inconvenience created.
Posted Aug 23, 2016 - 17:02 CEST
Monitoring
The issue has been fixed and reported as resolved. For security reasons we will monitor it closely for the next hours.
Posted Aug 23, 2016 - 13:05 CEST
Investigating
An irregularity in parts of the network has been reported from the Scandinavian region.
This is currently being investigated.
Posted Aug 23, 2016 - 11:21 CEST