Network problems
Incident Report for Paymill GmbH
Resolved
The network services are full functional again.

Thank you very much for your patience and we're sorry if this caused any inconvenience.

If you have any further questions please contact our support team via support@paymill.com.
Posted Jun 06, 2016 - 13:00 CEST
Identified
Due to an irregularity in parts of the network sporadically some transactions cannot be processed correctly.
Posted Jun 06, 2016 - 11:35 CEST